On 09-09-2026 21:32, Jarkko Sakkinen wrote:
On Wed, Sep 02, 2026 at 02:52:17PM +0530, Kuldeep Singh wrote:
On 01-09-2026 19:16, Jarkko Sakkinen wrote:
Short summary has a different driver name that is implemented i.e., it should has "tpm_qcom", not "tpm-qcom".
True, let me make more generic like "Introduce Qualcomm TPM driver" instead of having driver filename in commit title for any confusion.
MAINTAINERS | 7 + drivers/char/tpm/Kconfig | 9 ++ drivers/char/tpm/Makefile | 1 + drivers/char/tpm/tpm_qcom.c | 371 ++++++++++++++++++++++++++++++++++++++++++++ drivers/char/tpm/tpm_qcom.h | 82 ++++++++++
Rename it as tpm_qcom_tee just to be aligned on how Microsoft's fTPM driver is named.
I'd say firstly microsoft ftpm driver should be renamed. For example, MS ftpm is based on optee(session based context) whereas Qcom tpm driver is based on qcomtee(part of same TEE subsystem but uses completely different mink-ipc based sharing mechanism). So, it's completely different driver compared to MS.
My suggestions:
- Rename MS driver i.e tpm_ftpm_tee.c -> tpm_microsoft.c
- Rename Qcom driver i.e tpm_qcom.c -> tpm_qcom.c
This goes for argument using tpm_qcom.c but we don't rename ko's in normal circumstances (unfortunately so).
Sure, we can keep tpm_qcom.c then and don't update tpm_ftpm_tee.c I hope I understand you correctly.
Kindly check v2 posted after addressing comments for latest. https://lore.kernel.org/lkml/20260907-tpm_qcom_driver-v2-0-71a6b1752da8@oss....